Servidores no operativos
Incident Report for Worksible
Resolved
Problema solucionado, sentimos las molestias
Posted Jan 02, 2021 - 12:46 CET
Investigating
Estamos investigando el problema
Posted Dec 27, 2020 - 11:38 CET
This incident affected: Worksible (Landing Page, Freelancer dashboard, Worksible for Business, Mailing, Chat, Payments, Auth).